1. [PHPMyAdmin] Krijg het niet geïnstalleerd.

Re: [PHPMyAdmin] Krijg het niet geïnstalleerd.

Graag gedaan :)
  • Graag gedaan :)
  • Het enige wat ik dan nog zou weten is (als je gebruikersnaam en wachtwoord écht goed zijn) heel phpMyAdmin verwijderen en opnieuw erop zetten.

    (Je database staat toch wel op dezelfde server als phpMyAdmin?)

    Zie edit. :)
  • Het enige wat ik dan nog zou weten is (als je gebruikersnaam en wachtwoord écht goed zijn) heel phpMyAdmin verwijderen en opnieuw erop zetten.

    (Je database staat toch wel op dezelfde server als phpMyAdmin?)
  • In principe heeft elke gebruiker standaard de rechten tot een bepaald aantal databases - als je met een gebruiker inlogt kijkt phpmyadmin welke databases deze gebruiker mag beheren en laat deze dan zien, dus je zou geen database hoeven in te vullen. Je kunt proberen je inloggegevens ook in te vullen bij control_user en control_pass, en je moet in ieder geval only_db leeglaten. Als dat niet werkt weet ik het verder ook niet <img alt=":)" src="/plugins/sceditor/emoticons/smile.png" />

    Helaas, dat werkt ook niet.

    Edit: Ik heb toch nog maar wat geprobeerd, en het blijkt, nu werkt het wel als het goed is. De host had gezegt dat mijn username dias_ooti was, maar dat bleek dus flac_ooti te zijn (flac.nu is de domeinnaam) ik zit nu dus in PHPMyAdmin. Hopen dat hij goed blijft werken :) . In ieder geval bedankt voor je hulp.
  • In principe heeft elke gebruiker standaard de rechten tot een bepaald aantal databases - als je met een gebruiker inlogt kijkt phpmyadmin welke databases deze gebruiker mag beheren en laat deze dan zien, dus je zou geen database hoeven in te vullen. Je kunt proberen je inloggegevens ook in te vullen bij control_user en control_pass, en je moet in ieder geval only_db leeglaten. Als dat niet werkt weet ik het verder ook niet :)
  • Wat staat er precies op op de bewuste regel (config.inc.php 847)? Het zou kunnen dat je niet kunt inloggen omdat er geen cookie ingesteld kan worden, omdat er voor de cookie al output is geweest (daar wijzen die waarschuwingen ook op).


    Ik heb dat inmiddels - hoop ik, ik zie de foutmeldingen niet meer- gefixed door een nieuwe config.inc.php te uploaden met m'n info, maar dat inloggen wil hij dus nog steeds niet. En normaal moet je toch ergens een database in kunnen vullen? want dat kan dus niet bij die config file misschien dat daarom het inloggen niet lukt.. anders weet ik het ook niet meer.
  • Wat staat er precies op op de bewuste regel (config.inc.php 847)? Het zou kunnen dat je niet kunt inloggen omdat er geen cookie ingesteld kan worden, omdat er voor de cookie al output is geweest (daar wijzen die waarschuwingen ook op).
  • Nou, de fout zegt dat je met de gebruikersnaam/wachtwoord combinatie waarmee je inlogt geen toegang krijgt tot de database. Dit zou kunnen komen doordat er een syntaxfoutje in config.inc.php staat (ook omdat er blijkbaar al output is voor het script, die kwam vanuit config.inc.php, regel 847) - roep dat bestand eens direct aan via de browser (gewoon http://domein.nl/pad/config.inc.php intypen) en kijk of je een syntax error krijgt. Zoniet, zet dan "auth_type" eens op "cookie": dan moet je via de browser inloggen, wat misschien omslachtiger is, maar soms beter werkt. Als dat allemaal niet werkt heb je gewoon de verkeerde logingegevens gebruikt <img alt=":)" src="/plugins/sceditor/emoticons/smile.png" />

    Trouwens, ik zou even het wachtwoord in je post vervangen door sterretjes, anders weet iedereen je inloggegevens zo.

    Ik heb m'n pw al verandert, het echte pw is dus niet pwhere ;) mijn hostess gaf me die MySQL gegevens dus die horen goed te zijn. Maar goed, even proberen.

    Edit: nog steeds errors:
    Nadat ik heb geprobeerd in te loggen krijg ik:

    Warning: Cannot modify header information - headers already sent by (output started at /home2/flac/public_html/ooti/PHPMyAdmin/config.inc.php:847) in /home2/flac/public_html/ooti/PHPMyAdmin/libraries/mcrypt.lib.php on line 21

    Warning: Cannot modify header information - headers already sent by (output started at /home2/flac/public_html/ooti/PHPMyAdmin/config.inc.php:847) in /home2/flac/public_html/ooti/PHPMyAdmin/libraries/auth/cookie.auth.lib.php on line 554

    Warning: Cannot modify header information - headers already sent by (output started at /home2/flac/public_html/ooti/PHPMyAdmin/config.inc.php:847) in /home2/flac/public_html/ooti/PHPMyAdmin/libraries/auth/cookie.auth.lib.php on line 562

    Warning: Cannot modify header information - headers already sent by (output started at /home2/flac/public_html/ooti/PHPMyAdmin/config.inc.php:847) in /home2/flac/public_html/ooti/PHPMyAdmin/libraries/auth/cookie.auth.lib.php on line 593


    Ook het inloggen geeft errors, hij pakt m'n info niet. M'n db is dias_ooti en m'n username ook kan alleen nergens die db invullen bij die config file en als ik inlog krijg ik
    #1045 - Access denied for user: 'dias_ooti@localhost' (Using password: YES)
    terwijl ik volgens mij toch echt de goede gegevens heb van m'n host. Hij wil gewoon niet inloggen..
  • Nou, de fout zegt dat je met de gebruikersnaam/wachtwoord combinatie waarmee je inlogt geen toegang krijgt tot de database. Dit zou kunnen komen doordat er een syntaxfoutje in config.inc.php staat (ook omdat er blijkbaar al output is voor het script, die kwam vanuit config.inc.php, regel 847) - roep dat bestand eens direct aan via de browser (gewoon http://domein.nl/pad/config.inc.php intypen) en kijk of je een syntax error krijgt. Zoniet, zet dan "auth_type" eens op "cookie": dan moet je via de browser inloggen, wat misschien omslachtiger is, maar soms beter werkt. Als dat allemaal niet werkt heb je gewoon de verkeerde logingegevens gebruikt :)

    Trouwens, ik zou even het wachtwoord in je post vervangen door sterretjes, anders weet iedereen je inloggegevens zo.
  • Sorry als het hier verkeerd staat, maar volgens een vriend kon ik het hier posten. Ik heb een probleem met PHPMyAdmin, ik moet het installeren om in mijn MySQL database te komen om er iets in te plaatsen voor PHPNuke, ik word gehost door iemand anders maar die kan -behalve een db maken- verder niets met MySQL. Maar, nu heb ik dus PHPMyAdmin erop gezet en die doet het niet. Ik heb al van alles geprobeerd maar ik snap echt niet waarom hij het niet doet. Dit is m'n error:

    Warning: Cannot modify header information - headers already sent by (output started at /home2/flac/public_html/ooti/PHPMyAdmin/config.inc.php:847) in /home2/flac/public_html/ooti/PHPMyAdmin/libraries/auth/config.auth.lib.php on line 81

    Warning: Cannot modify header information - headers already sent by (output started at /home2/flac/public_html/ooti/PHPMyAdmin/config.inc.php:847) in /home2/flac/public_html/ooti/PHPMyAdmin/libraries/select_theme.lib.php on line 98

    Welkom op phpMyAdmin 2.6.2-pl1

    phpMyAdmin probeerde met de MySQL server te verbinden maar de server weigerde de verbinding. Controleer de host, de gebruikersnaam en het wachtwoord in config.inc.php en zorg er voor dat deze overeenkomen met de informatie die u van de Beheerder van de MySQL server kreeg.

    Fout
    MySQL retourneerde:

    #1045 - Access denied for user: 'dias_ooti@localhost' (Using password: YES)

    Dit heb ik in config.inc.php staan (heb het gedeeltelijk gekopieerd):

    $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'host'&#93; = 'localhost'; // MySQL hostname or IP address $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'port'&#93; = ''; // MySQL port - leave blank for default port $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'socket'&#93; = ''; // Path to the socket - leave blank for default socket $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'connect_type'&#93; = 'tcp'; // How to connect to MySQL server &#40;'tcp' or 'socket'&#41; $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'extension'&#93; = 'mysql'; // The php MySQL extension to use &#40;'mysql' or 'mysqli'&#41; $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'compress'&#93; = FALSE; // Use compressed protocol for the MySQL connection // &#40;requires PHP &gt;= 4&#46;3&#46;0&#41; $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'controluser'&#93; = ''; // MySQL control user settings // &#40;this user must have read-only $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'controlpass'&#93; = ''; // access to the &quot;mysql/user&quot; // and &quot;mysql/db&quot; tables&#41;&#46; // The controluser is also // used for all relational // features &#40;pmadb&#41; $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'auth_type'&#93; = 'config'; // Authentication method &#40;config, http or cookie based&#41;? $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'user'&#93; = 'dias_ooti'; // MySQL user $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'password'&#93; = 'pwhere'; // MySQL password &#40;only needed // with 'config' auth_type&#41; $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'only_db'&#93; = 'dias_ooti'; // If set to a db-name, only // this db is displayed in left frame // It may also be an array of db-names, where sorting order is relevant&#46; $cfg&#91;'Servers'&#93;&#91;$i&#93;&#91;'verbose'&#93; = ''; // Verbose name for this host - leave blank to show the hostname
    Ik hoop dat jullie mij kunnen helpen, ik heb niet veel verstand van PHP dus niet met moeilijke termen aankomen a.u.b. ^_^'

Plaats reactie

Wanneer je een reactie plaatst ga je akoord
met onze voorwaarden voor reacties.

Log in om te reageren